Oracle Warehouse Builder Not Much Cop

This won't come as a surprise to people who have used the tool but I'm getting to the end of my tether with Oracle Warehouse Builder. Architecturally it stinks.

We've got a number of mappings which we use to populate a reporting mart in our Oracle Applications system. We are upgrading our Oracle Applications sytem. Part of this is a database upgrade to the latest shiny Oracle database.

Because we've done that we have to upgrade from Oracle Warehouse Builder 9.2 to 10.1. I've upgraded the repository successfully, but every time we create a new applications environment we have to install the full version of OWB onto the server and run one script against the target database to upgrade the runtime repository.

In this age of network ubiquity Oracle are forcing me to install a full server product. My DBA is not going to be a happy bunny.

It wouldn't be so much of a problem if this was an isolated issue, but every time we clone our environment or want to make even a simple change to a mapping OWB just gets in the way. My back of a fag packet estimate is that I would have saved about fifty person days if we had just developed our extracts in plain old fashioned PL/SQL.

Update: I stand corrected. There is, as referenced on the first page of the installation and upgrade manual, a script to upgrade a runtime repository in place. You'll be unsurprised to hear that we can't get it to work. Or that Oracle's support site (MetaLink) has nothing on the error messages we are seeing.